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1  Introduction 

With Live Section, creating sections and cut-away 
views is easy. With Live Section, you can 
interactively preview sections through complex 
assemblies or buildings, then section the entire 
structure (or, if you prefer, only the selected 
geometry) with a single mouse click. 
 
Interactive Placement 

Live Section allows you to create sections from the 
view you'll be using them from-- plan, elevation, or 
any arbitrary viewing angle. The sectioning plane 
is always perpendicular to your viewpoint. In 
Target mode, the sectioning plane is placed so it 
passes though any object clicked on. In Move 
mode, clicking and dragging in the modeling 
window moves the sectioning plane towards or 
away from your position. 
 
Preview modes 

Several preview modes provide feedback while 
you position the sectioning plane.  
 
True Sections 

Section your entire project, or just a part of it, with a 
single click. Sections are automatically placed in groups or joined into a single entity 
(your choice), and given meaningful names (e.g., "2D Section Top"). With 3D sections, you 
can opt to delete (or keep or ghost) resulting sectioned objects that are between the 
viewpoint and the sectioning plane, allowing you to effortlessly create cutaway views.  
Live Section will even section symbols! 
 
Unstoppable 

If Live Section encounters 'incompletely formed' objects, or objects that are inappropriate 
for the specified section type, it will simply skip them and continue sectioning everything 
that can be sectioned. When finished, Live Section will notify you if troublesome objects 
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were found, and ask if you'd like to ignore them, automatically select them, or tag the 
objects' names so you can deal with them later. The automatic-selection option makes it 
easy to fix your objects afterward using formZ's Object Doctor--- just click on the Object 
Doctor tool and all the troublesome objects are inspected, one at a time. 
 

2  Getting Started 

2.1  Finding the Live Section Tool 

After installing the Views + Navigation Collection, a new group of tools will be added to 
your tool palette, called Views + Navigation. You'll find the Live Section Tool in this new 
group. (If you want, you can move your new tools to another location by selecting 
Palettes > Customize Tools.) 

2.2  Setting up a key shortcut for Live Section 
It is possible to set up a key shortcut for Live Section. In formZ, select Help > Modeling 
Tools… In the resulting dialog, double-click on the Live Section Tool icon and create a 
new key shortcut. 

2.3  Using the Help System 

This manual can be launched from formZ by shift-clicking on the Live Section Tool icon in 
the tools palette. 
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3  Using Live Section 
 
Sections 3.1 and 3.2 below detail how to prepare for a section. After positioning the 
sectioning plane. Section 3.3 treats the topic of section renderings and section 3.4, how to 
create true geometric sections. To begin, select the ‘Live Section’ tool and inspect the 
Tool Options palette. 
 

3.1  Selecting a preview mode 

Live Section Tool provides several modes for previewing your section: 
 
Clip Rendering 

When this checkbox is enabled, everything lying between the sectioning plane and your 
viewpoint is omitted, or ‘clipped’. As the section plane is repositioned using the tools 
detailed in the next section, the sectioned rendering will be updated in real time. (Live 
Section is manipulating the ‘clip hither’ parameter found in formZ’s view options.) 
 
As Slice 

When enabled, the preview will display a ‘slice’ of the model where it intersects with the 
section plane. (Live Section is manipulating both the ‘clip hither’ and ‘clip yon’ 
parameters.) The thickness of this slice can be changed in Preferences. 
 
Show Plane During Section Adjustment 

When this checkbox is enabled, a plane representing the section is drawn during 
repositioning (see the Position tool option, below) . Unlike the Clip Rendering preview 
option, this plane is visible in all windows.  
 
In the sectioning window or frame, this option is best used with Interactive Shaded mode. 
If Transparencies are enabled (Display > Display Options… > Interactive Shaded), the 
plane will display as 50% transparent; if not, it will be opaque. 
 
In orthographic views, wireframe mode is often the best choice, as the plane can be seen 
as a single line passing though the model. 
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Tip When using the ‘Show Plane’ option, you can inspect the section plane from 

several angles by opening additional windows or frames. 

 
 
3.2  Adjusting the section plane position 

Two tool options are provided for positioning the sectioning plane: 
 
Target 

Click on the icon, then on any object in the modeling window. The section plane 
will be positioned so that it passes through the center of the chosen object. Note 
that you can still click on and target objects even when they are not visible (due 

to the ‘Clip Rendering’ preview). 
 
 
Position 

Click on the icon, then again in the modeling window. Moving the cursor up will 
move the section plane further away from your position; moving it down will 
move the section plane closer. When you are satisfied with the position of the 

plane, click again to confirm. (You may opt for horizontal cursor movement instead. See 
Preferences). 
 
You may also adjust distance by moving the slider or by typing a value directly into the 
text box, which indicates the distance from the eye point to the section plane. 
 
 
Cursor Sensitivity 

This slider controls how far the section plane is moved per a given mouse movement. 
Position the slider to the left for fine adjustment, and to the right for coarse adjustment. 
 

Tip A good method for positioning the sectioning plane:  

1.  Using the Target mode, select an object in the general vicinity where you 

want to create the section 

2. Turn on one of the preview modes described above.  

3.  Use the Position mode to fine-tune the section. 
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3.3  Creating rendered sections 

After you have positioned the section plane, you can make a rendering in any of formZ’s 
rendering modes. RenderZone renders are great for ‘cutaway’ views, while Hidden Line 
renderings are useful for making sections that  can be pasted into formZ’s drafting 
environment. 
 
How to place a rendered Hidden Line section into a formZ drafting project 

1. Render the section in Hidden Line Mode. 
2. Switch to a drafting project (or create a new one). 
3. Select Edit > Paste From Modeling… In the resulting dialog, select your hidden line 
rendering from the list, and enable ‘Each 3D Segment As A Single Line’ and ‘Remove 
Duplicate And Overlapping Lines’. In most cases, you will want to enable ‘Join All 
Segments’ as well. 
 
How to import a section into Illustrator 

1. Follow steps 1 – 3 above. 
2. With the draft window active, select File > Export Image > Illustrator. 
 
 

Tip  ‘Cleaner’ sections can often be obtained by creating a true 2D or 3D section 

(see section 3.4), then copying and pasting the true section into the drafting 

environment. 
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3.4  Creating true geometric sections 

After you have positioned the sectioning plane, you can create a true geometric section of 
all (or part of) your model. First, set the sectioning options (below) as desired, then click 
on the True Section Button, then click anywhere in the modeling window. New, sectioned 
objects will be created and assigned meaningful names.  
 
Selected Objects / All Visible 

Determines whether all visible objects in the file, or only currently selected objects, will 
be sectioned. 
 
2D / 3D 

Determines if a 2D or a 3D section will be created. 
 
Resulting Objects Before Section Plane 

Determines whether resulting sections lying between the section plane and the viewpoint 
are kept, ghosted, or deleted.  This option is useful when creating cut-away views. It 
applies to 3D sections only. 
 
Surface Style 

Controls whether the cut faces of the 2D or 3D section are assigned the same surface 
style of the original cut object(s) (keep), or the style currently selected in the surface 
styles palette (assign new). 
 
Create Matching View 

Upon sectioning, the current view will be given a meaningful name and saved to the 
views palette. This option is useful when one needs to return to the same spot later for 
further rendering passes, or to generate additional sections with the same orientation but 
different position. 
 
True Section 

To create a section, click on the Section icon, then anywhere in the modeling 
window. All selected geometry will be sectioned, including symbol instances, if 
this option is selected in Live Section Preferences. 
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Tip After creating a 2D section, you can paste it into formZ’s drafting environment. 

This will generally produce a cleaner result than pasting from a Hidden Line 

rendering. 

 
 

3.5  Finding and Fixing Un-sectionable Objects with the Section Diagnosic 

 
If Live Section encounters 'incompletely formed' objects, or objects that are inappropriate 
for the specified section type, it will simply skip them and continue sectioning everything 
that can be sectioned. When finished, Live Section will notify you if un-sectionable 
objects were found, and provide three options to assist you. This warning is only 
displayed when un-sectionable objects are encountered. 
 
Ignore and continue 

The default option is to ignore the un-
sectionable objects and continue working. 
This option simply dismisses the warning 
dialog. Choose this option if you know 
that the offending objects are not 
necessary for the section (because you 
have previously run a section with the 
‘Select Objects’ option and have 
determined that the offending objects are 
not critical). 
 
Select Objects 

Clicking on this button will select all un-sectionable objects and dismiss the warning 
dialog. [Note: this option is disabled if ‘Status of Objects’ is set to ‘Delete.’] A suggested 
recovery workflow follows: 
1. Visually inspect the highlighted objects to determine if they have are relevant to your 
section. Some objects, such as open wires (which can never be sectioned), can be safely 
ignored.  
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2. If some skipped objects are important, click on formZ’s Object Doctor Tool. In Tool 
Options, click on the ‘All’ Button within each tab, and enable ‘Preview’ under the ‘Action’ 
parameter. Finally, with the objects still selected, click anywhere in the modeling window.  
3. The objects will be loaded into the Object Doctor one at a time, where you can inspect 
them in greater detail. Some problems, such as non-planar surfaces, can be corrected 
from within the object doctor. See the formZ reference manual for more details. 
 
Tag object names and select 

Clicking on this button will select all un-sectionable objects, append each object name 
with the tag “[*]” and dismiss the warning dialog. This option makes it impossible to 
loose track of the un-sectionable objects. In the future, you can select them all again by 
selecting Edit > Select By…. Under the ‘Attributes’ tab, enable the ‘Name’ checkbox, 
select ‘Contains’ from the pull-down menu, and type ‘un-sectionable’ into the text box. 
 
Notes: The tag objects option is disabled if ‘Status of Objects’ is set to ‘Delete.’ Also, if an 
object’s name is longer than 27 characters, the tag cannot be appended. 
 
False-Positives 

Live Section’s diagnosic system attempts to find each and every case where an object 
may cause sectioning problems. Ocassionally, this sensitivity may result in a false-
positive, where an object very near the sectioning plane, but not actually intersecting 
with it, will be identified as un-sectionable. If this happens, simply dismiss the dialog. You 
can turn off the diagnostic warning if you wish. 
 
Turning off the Section Diagnosic 

You may disable the diagnostic warning dialog in the preferences tab if you would prefer 
that Live Section not inform you of these cases (as in versions 1.1 and below).  
 
A table of typical sectioning problems and solutions 

Object Type / 

Description 

Affects 

Section Type 
Solutions 

Open Wire 2D and 3D • Section not meaningful. Close wire or ignore. 

Double-sided 
surface 

2D and 3D 
• Make single-sided with formZ’s Make One 
Sided/Two Sided tool. 

Solid with non-
planar face(s) 

3D 
• Triangulate Object / Face with formZ’s Triangulate 
Tool. 
• Edit or recreate object if face should be planar. 
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4  Preferences 
 
Operand Status 

Functions identically to ‘Status of Objects’ 
found elsewhere in formZ. 
 
Section Symbols 

When enabled, copies of any symbols are 
exploded and sectioned. The original symbol 
instances are not changed. When disabled, 
symbols are skipped. (Disable this feature if 
the exploded symbols are resulting in an 
excess of unnecessary objects.) 
 
Join Resulting Objects 

When enabled, all resulting section objects 
are joined into a single object. (If necessary, 
you may separate them later with formZ’s 
‘Separate’ tool.) When disabled, all resulting 
section objects are placed into a single group. 
 
Prompt For Section Name 

When enabled, you are alerted to name the 
section if it is successfully created. This name 
will be given to both the group/joined object 
and the automatically saved view (if 
applicable). When disabled, resulting entities 
will be automatically assigned a meaningful 
name. 
 
Turn Off Preview After Section 

Determines whether view clipping is turned off automatically after a section is made. 
 
Show Warnings 

Enables/Disables warnings as described in section 3.5. 
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Slice Thickness 

Determines the thickness of the preview slice described in section 3.1. 
 
Section Planes Slider Max 

Determines the maximum value of the Position slider found in ‘Options’. 
 
Cursor Movement 

• Vert: Vertical cursor movement is used to position the section plane while in Position 
mode.  
• Horz: Horizontal cursor movement is used to position the section plane while in Position 
mode. 
 
Saving Preferences 

Changes made to Live Section Preferences are by default only retained for the duration 
or your modeling session. As with all other tools, if you want to save your preferences for 
subsequent modeling sessions, go to formZ's general preference dialog  (formZ > 
Preferences… System > General) and save a new preference set (or save over your old 
one). All Live Section preferences, as well as the options found under the ‘True 
Sectioning’ heading in ‘Options’, will be saved. 
 
formZ tech support strongly recommends that users edit and save their preferences only 
at the beginning of the modeling session. 
 

5  Obtaining version information 
 
Click on the Pylon Logo in Tool Options for version information and credits. 

6  Known issues 
The following minor issues are due to bugs or limitations in the formZ Application 

Programming Interface (API). They will be corrected when ADS resolves the underlying 

problems. 

 

• None
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