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1  Introduction 

The Navigator palette provides a number of window-related 
functions designed to make your formZ modeling workflow more 
efficient. 
 
Quick Views 

Have you ever wanted a an easy way to jump between 2 or 3 
temporary locations in your project--- while in the middle of a 
drawing operation? We have. Three buttons are provided for 
managing temporary views in your project. Control-clicking on a 
button stores the current view; clicking on the button restores the 
view stored in the button. Each button/view can be assigned a 
key shortcut, so you can toggle between views without moving 
your cursor or taking your eyes off your drawing. Quick, easy, 
and you wont clog your views palette with temporary views 
you'll only need for the next 5 minutes.  
 
Find that elusive view 

Have 40 views, and can't find the one you're looking for to match that render from 
several days ago? No problem. Click on the + or - buttons to cycle through all the saved 
views in your project until you find it. With your eyes on the modeling window, rather 
than the views palette, this is fast and painless. 
 
Stay Focused 

Effortlessly keep your work in the center of your window with Navigator's focusing 
features. When enabled, AutoFocus continuously updates your view so that selected 
topologies appear at the center of the modeling window. Manual Focus works much the 
same, but focuses only when pressed. Both focus options work well in combination with 
formZ's direct view navigation shortcuts: for instance, formZ's "set view interactive 
(center of interest)" will always revolve around your selection, rather that some 
previously chosen point. 
 
Options are provided for maintaining the same view heading when focusing, and for 
synchronizing the focus of some or all of the viewports in multiple-frame windows. 
AutoFocus can be enabled and disabled on a per-window basis (like grid snapping) 
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allowing you to enable it where appropriate (some modeling windows), and keep it off 
where not ('hero' rendering windows). Both Auto- and Manual Focus can be assigned key 
shortcuts. 
 
Grid Management 

Navigator's grid management makes precision drawing easier and more intuitive. 
Navigator introduces Grid Presets, which allow you to logically group your commonly 
used grid snaps, name them, and associate each with an appropriate reference grid. For 
instance, your presets might include a 1/8" grid snap associated to a 1 inch / 8 division 
display, and a 1/16" grid snap associated to a 1 inch / 16 division display. When you 
select a Grid Preset from the presets pop-up menu, the grid snap, reference grid, and 
reference grid divisions are all changed at once. For even greater efficiency, you can skip 
to the next or previous Grid Preset using key shortcut equivalents. Switching presets 
works even while in the middle of a drawing operation. 
 
Groups of related Grid Presets are stored in user-editable template files. Navigator comes 
bundled with several templates. English Small, English Machining, and Metric, which may 
be all you'll ever need. If not, you can modify them (or create entirely new templates) to 
suit your workflow. You can change the Grid Preset template used in Navigator at any 
time by selecting the 'Open' option from the pop-up menu.  
 
Additionally, you can directly change the reference grid size, grid divisions, or grid snap 
by typing values into the text fields. Pressing the + or - buttons increases or deceases 
each value. 
 

2  Getting Started 

2.1  Showing and hiding Navigator 
To toggle Navigator’s visibility, select Palettes > Navigator.  

2.2  Setting up a key shortcut to toggle Navigator visibility 
To set up a key shortcut to show and hide Navigator, select Help > Menus… In the 
resulting dialog, double-click on the item Navigator under the Palettes menu, then create 
a new key shortcut. 
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2.3  Setting up key shortcuts to activate Navigator’s functions 
To get the most out of your new plugin, we recommend that you assign key shortcuts to 
the following Navigator functions: 
 

Quickview 1 
Quickview 2 
Quickview 3 
Auto Focus 
Manual Focus 
Grid Snap 
Grid Preset: Previous 
Grid Preset: Next 

 
Each of these Navigator functions can be activated by an associated command in the 
Extensions menu. Select Help > Menus… In the resulting dialog, double-click on each 
commands under the Extensions menu, then create a new key shortcut for it. 
 

NOTE The Grid Snap toggle is designed to be used in place of formZ’s existing grid 

snap toggle. (This replacement is necessary because the native snap toggle will 

not update Navigator’s grid snap icon.) Simply re-assign your current grid snap 

shortcut to this command. 

 
 

3 Using the Help System 
You can launch this manual from formZ by holding down the shift key and selecting 
Navigator from formZ’s Palettes Menu. 
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4  Using Navigator 

4.1  Navigator Views 

 
Quickviews 

Control-clicking (Mac) or Control-Alt-clicking (PC) on a button stores the 
current view; clicking on the same button later restores that view. Each 
view may also be restored by selecting one of the Quickview 

commands from formZ’s Extensions menu, or by pressing its key shortcut. (See section 
2.3 on setting up key shortcuts.) 
 
 
View Cycle 

If a saved view is currently active, clicking on the (+) button selects and restores the 
next view in the views palette; if not, the first view in the views palette is selected. 
If a saved view is currently active, clicking on the (–) button selects and restores the 
previous view in the views palette; if not, the last view in the views palette is 

selected. Repeatedly clicking on either button cycles though all the views in the project. 
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4.2  Navigator Focus 

 
In the discussion below, the term ‘frame/window’ is used to refer to either a frame within 
a window (if the window has frames enabled) or the entire window (if the window does 
not have frames enabled). 
 
Auto Focus 

Click on this icon to enable or disable Auto Focus for a frame/window. When 
enabled, and a point, segment, face, or object is selected with the Pick Tool or 
from the objects palette, the center of interest of the current frame/window will 

be moved to the center of the selection. If multiple entities are picked, the center of 
interest will move to the average centerpoint of the selected entities. The frame/window 
focus updates continuously, as entities are selected and deselected.  
 
Auto Focus is be enabled or disabled on a per-frame basis (if frames are enabled) or per-
window basis (if they are not). The state of Auto Focus for a given frame/window is 
remembered between formZ sessions. 
 
Manual Focus 

Works like Auto Focus, but only focuses only when explicitly pressed. Can be 
used when Auto Focus is active to re-focus on already selected objects. 
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 View Heading Lock 

When enabled, and a focus occurs in a non-orthographic view, the eye point is 
moved along with the COI, so that the view heading and distance between the 

eye point and COI remain the same. When disabled, only the COI is moved. 
 
In orthographic views, the view heading lock is always applied regardless of the status of 
this checkbox. 
 
 

 
View Heading Lock disabled: 

After the sphere is selected, only the COI is moved. 

 

 
View Heading Lock enabled: 

After the sphere is selected, both the COI and eye are 
moved; heading and distance remain constant. 
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Frames Synchronization 

When this checkbox is enabled, and a manual or auto focus occurs within a 
window frame, all other frames within the same window that have Auto Focus 

enabled are focused as well.   
 
For example, imagine a window has been divided into 4 frames. Frames Synchronization 
is turned on, frames 1, 2, and 3 have Auto Focus turned on, and frame 4 has Auto Focus 
off. If an object is selected in frame 1, it will become the focus in that frame, as well as in 
frames 2 and 3. Frame 4 will remain unaffected. On the other hand, if an object is 
selected in frame 4, no focusing will take place in any of the frames, because autofocus 
has not been enabled for that frame. 
 
Alternately, if Frames Synchronization is turned off, and an object in frame 1 is selected, 
autofocus will occur in only that frame. 
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4.3  Navigator Grids 

 
Reference Grid Module 

Clicking on this icon toggles the reference grid display in the current window. 
The reference grid module (a dimension given in the current working units) can 
be changed by typing a new value into the text box. In Navigator, the grid 

module is always identical in X, Y, and Z. 
 
Reference Grid Divisions 

Clicking on this icon toggles the reference grid display in the current window. 
The reference grid divisions (the number of subdivisions between each module) 
can be changed by typing a new value into the text box.  

 
Grid Snap 

Clicking on this icon toggles grid snapping in the current window. The reference 
grid divisions (the number of subdivisions between each module) can be 
changed by typing a new value into the text box. In Navigator, the grid snap for 

X, Y, and Z is always the same. 
 
Increase and Decrease buttons 

Clicking on these buttons will increase or decease the value in the adjacent 
number box. The degree and kind of adjustment is determined by the options 

in Navigator Preferences (see Preferences, below). By default, when the Increase button 
is pressed, the number is doubled, and when the Decrease button is pressed, it is halved. 
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What is a Grid Preset? 

A Grid Preset is an association between a particular grid 
snap, a reference (display) grid module, and a reference 
grid division. You can create your own Grid Presets, name 
them, and store them in logically related groups called 
Grid Presets Templates.  
 
Selecting a Grid Preset 

A Grid Preset is invoked by selecting it from the Grid 
Presets pop-up menu, or by pressing the Grid Preset: Next 
or Grid Preset: Previous key shortcuts until the desired 
shortcut is selected. (Section 2.3 describes how to assign 
these shortcuts.) 
 
When a Grid Preset selected, the grid snap, reference grid, and reference grid divisions 
are all changed simultaneously, according to the data stored in the preset. Switching 
presets works even while in the middle of a modeling operation. 
 
What is a Grid Preset Template File? 

Groups of logically related Grid Presets 
(such as ‘Metric’ or ‘English Machining’)  
are store together in a file called a Grid 
Presets Template. When formZ is first 
launched, the Navigator will load the 
template called ‘Default Grid 
Presets.grd’, located within the 
‘Plugins/Pylon Technical/Views and 
Navigation/Grid Presets/’. If you wish, 
you can change the grid presets in this file. 
 
Opening a new Grid Preset Template File 

You can load a new Grid Preset Template at any time by selecting ‘Open’ from the top of 
the Grid Presets pop-up menu. Grid Template Presets files can be recognized by their 
extension, “.grd.” Several  useful templates are included. 
 
Section 4 describes how to create and edit Grid Preset Template Files. 
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4  Creating and Editing Grid Preset Template Files 
 
Editing a grid presets template file 

Launch a plain text editor (such as TextEdit on the Mac, or Notepad on the PC), then open 
a grid preset template file. Edit the file to suit your needs, then save under a new 
filename. To have formZ load a particular set of presets by default, name the file ‘Default 
Grid Presets.grd’, and save it to the folder ‘Plugins/Pylon Technical/Views and 
Navigation/Grid Presets/’. 
 
Each line in the file represents a grid preset. The format is as follows: 
 

 
 

preset_name 
[alphanumeric, 
no spaces] 
 

tab  
 

ref_grid_module 
[fractional number] 
 

tab 
 

ref_grid_divisions 
[whole number] 
 

tab 
 

grid_snap 
[fractional 
number] 
 

end of line 

 
Note that fractional numbers must be expressed in decimal form (0.25, not ¼). 
 
Navigator will load the first 15 grid presets contained in a grid preset file. 
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5  Preferences 
 
Preferences 

Pressing this button invokes Navigator 
preferences.  

 
Palette Layout 

Selecting ‘Compact’ will save a bit of screen real 
estate by presenting the Navigator Palette without 
the text headings at the beginning of each section 
(and their respective borders). Normal’ offers a more 
clear presentation, but occupies a bit more space. 
 
+/– Button Action 

Multiply/Divide: If this option is selected, and the (–) 
button below each of the grid text boxes is clicked, 
the value in that text box will be divided by the 
number indicated in the ‘Value’ preference. If the (+) button is clicked, the value is instead 
multiplied by this number. 
Add/Subtract: Same as above, by clicking on the (–) sign subtracts the indicated number 
from the grid text box value, and (+) adds to it. 
 
Eye 

Frames 

These settings are also stored when formZ general preferences are stored. 
 
Saving Preferences 

Changes made to Navigator Preferences are by default only retained for the duration or 
your modeling session. As with all other tools, if you want to save your preferences for 
subsequent modeling sessions, go to formZ's general preference dialog  (formZ > 
Preferences… System > General) and save a new preference set (or save over your old 
one). All Navigator preferences, as well as the state of the view heading (eye icon) and 
focus frames (frames icon), will be saved. 
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formZ tech support strongly recommends that users edit and save their preferences only 
at the beginning of the modeling session. 
 

7  Known Issues 
 

The following minor issues are due to bugs in the formZ Application Programming 

Interface (API). They will be corrected if/when ADS attends to the underlying problems. 

 

Autofocus 

• If points of a facetted object are moved when Auto Focus is enabled, the focus will follow 

the points. This is not dangerous, but can be impractical. Workaround: Turn off autofocus 

when moving points. The underlying problem has been reported to ADS as a bug. 

 

• When a topology is deselected, Auto Focus will focus on the object that was just 

deselected. The underlying problem has been reported to ADS as a bug. 

 

• Currently, when an object is deselected, then selected again, it will not be re-focused 

upon. Workaround 1: Click on the ‘Manual Focus’ icon. Workaround 2: Select another 

object, then select the first object again. The underlying problem has been reported to 

ADS as a bug. 
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